首页 互联网正文

ubuntu安装flash失败怎么办?

ubuntu安装flash失败怎么办?我用的还是ubuntukylin版,操,结果装完连youku都看不到。一看原来差flash插件,点一下本已为就会安装好的,结果说找不到。蛋疼,国产能不能把这个弄完善一点?

好了,那我们来说一下,如呆在ubuntu上安装flash插件。

webkit-text-stroke-width: 0px; display: inline !important; float: none; background-color: rgb(255, 255, 255);">ubuntu默认浏览器firefox。按理在网页上flash占位的“安装插件”点击就可跳至adobe官网下载页面,能侦测到当前的ubuntu系统firefox浏览器(http包头),并完成安装,比如下载apt格式的安装包等 等 。然而这个功能有时却工作不正常。点击之后并未下载安装,而是提示选择打开的程序,或许有个程序可以打开(apt-get?),懒得研究了,还是看看用命令行方式在ubuntu软件库里安装flash插件的方法 吧。

 
webkit-text-stroke-width: 0px; display: inline !important; float: none; background-color: rgb(255, 255, 255);">hheongrong@hheongrong-ThinkPad-T410:~$ sudo -i
[sudo] password for hheongrong:
root@hheongrong-ThinkPad-T410:~# apt-get install flashplugin-
flashplugin-installer           flashplugin-nonfree-extrasound
root@hheongrong-ThinkPad-T410:~# apt-get install flashplugin-nonfree-extrasound 正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
将会安装下列额外的软件包:
  flashplugin-installer gcc-4.9-base:i386 libc-dev-bin libc6 libc6:i386
  libc6-dbg libc6-dev libgcc1:i386 libnspr4 libnspr4-0d libnss3-1d
建议安装的软件包:
  x-ttcidfont-conf ttf-mscorefonts-installer ttf-bitstream-vera ttf-dejavu
  ttf-xfree86-nonfree xfs glibc-doc glibc-doc:i386 locales:i386
推荐安装的软件包:
  flashplugin-installer:i386
下列【新】软件包将被安装:
  flashplugin-installer flashplugin-nonfree-extrasound:i386 gcc-4.9-base:i386
  libc6:i386 libgcc1:i386 libnspr4-0d libnss3-1d
下列软件包将被升级:
  libc-dev-bin libc6 libc6-dbg libc6-dev libnspr4
升级了 5 个软件包,新安装了 7 个软件包,要卸载 0 个软件包,有 344 个软件包未被升级。
需要下载 14.4 MB 的软件包。
解压缩后会消耗掉 10.2 MB 的额外空间。
您希望继续执行吗? [Y/n] y
获取:1 http://cn.archive.ubuntu.com/ubuntu/ trusty/main gcc-4.9-base i386 4.9-20140406-0ubuntu1 [13.9 kB]
获取:2 http://cn.archive.ubuntu.com/ubuntu/ trusty-updates/main libc6-dev amd64 2.19-0ubuntu6.1 [1,915 kB]
获取:3 http://cn.archive.ubuntu.com/ubuntu/ trusty-updates/main libc-dev-bin amd64 2.19-0ubuntu6.1 [69.0 kB]
获取:4 http://cn.archive.ubuntu.com/ubuntu/ trusty-updates/main libc6-dbg amd64 2.19-0ubuntu6.1 [3,459 kB]
获取:5 http://cn.archive.ubuntu.com/ubuntu/ trusty-updates/main libc6 amd64 2.19-0ubuntu6.1 [4,739 kB]
60% [5 libc6 3,164 kB/4,739 kB 67%]                              142 kB/s 40秒^[获取:6 http://cn.archive.ubuntu.com/ubuntu/ trusty-updates/main libc6 i386 2.19-0ubuntu6.1 [4,004 kB]
77% [6 libc6:i386 831 kB/4,004 kB 21%]                            343 kB/s 9秒^[获取:7 http://cn.archive.ubuntu.com/ubuntu/ trusty/main libgcc1 i386 1:4.9-20140406-0ubuntu1 [47.8 kB]
获取:8 http://cn.archive.ubuntu.com/ubuntu/ trusty-updates/main libnspr4 amd64 2:4.10.2-1ubuntu1.1 [110 kB]
获取:9 http://cn.archive.ubuntu.com/ubuntu/ trusty/main libnss3-1d amd64 2:3.15.4-1ubuntu7 [9,298 B]
获取:10 http://cn.archive.ubuntu.com/ubuntu/ trusty-updates/universe libnspr4-0d amd64 2:4.10.2-1ubuntu1.1 [6,584 B]
获取:11 http://cn.archive.ubuntu.com/ubuntu/ trusty-updates/multiverse flashplugin-installer amd64 11.2.202.400ubuntu0.14.04.1 [6,868 B]
获取:12 http://cn.archive.ubuntu.com/ubuntu/ trusty/multiverse flashplugin-nonfree-extrasound i386 0.0.svn2431-3ubuntu1 [8,562 B]
下载 14.4 MB,耗时 1分 14秒 (193 kB/s)                                         
正在预设定软件包 ...
Selecting previously unselected package gcc-4.9-base:i386.
(正在读取数据库 ... 系统当前共安装有 145628 个文件和目录。)
Preparing to unpack .../gcc-4.9-base_4.9-20140406-0ubuntu1_i386.deb ...
Unpacking gcc-4.9-base:i386 (4.9-20140406-0ubuntu1) ...
Preparing to unpack .../libc6-dev_2.19-0ubuntu6.1_amd64.deb ...
Unpacking libc6-dev:amd64 (2.19-0ubuntu6.1) over (2.19-0ubuntu6) ...
Preparing to unpack .../libc-dev-bin_2.19-0ubuntu6.1_amd64.deb ...
Unpacking libc-dev-bin (2.19-0ubuntu6.1) over (2.19-0ubuntu6) ...
Preparing to unpack .../libc6-dbg_2.19-0ubuntu6.1_amd64.deb ...
Unpacking libc6-dbg:amd64 (2.19-0ubuntu6.1) over (2.19-0ubuntu6) ...
Preparing to unpack .../libc6_2.19-0ubuntu6.1_amd64.deb ...
Unpacking libc6:amd64 (2.19-0ubuntu6.1) over (2.19-0ubuntu6) ...
Selecting previously unselected package libc6:i386.
Preparing to unpack .../libc6_2.19-0ubuntu6.1_i386.deb ...
Unpacking libc6:i386 (2.19-0ubuntu6.1) ...
Processing triggers for man-db (2.6.7.1-1) ...
正在设置 libc6:amd64 (2.19-0ubuntu6.1) ...
Processing triggers for libc-bin (2.19-0ubuntu6) ...
Selecting previously unselected package libgcc1:i386.
(正在读取数据库 ... 系统当前共安装有 145937 个文件和目录。)
Preparing to unpack .../libgcc1_1%3a4.9-20140406-0ubuntu1_i386.deb ...
Unpacking libgcc1:i386 (1:4.9-20140406-0ubuntu1) ...
正在设置 gcc-4.9-base:i386 (4.9-20140406-0ubuntu1) ...
正在设置 libc6:i386 (2.19-0ubuntu6.1) ...
正在设置 libgcc1:i386 (1:4.9-20140406-0ubuntu1) ...
Processing triggers for libc-bin (2.19-0ubuntu6) ...
(正在读取数据库 ... 系统当前共安装有 145938 个文件和目录。)
Preparing to unpack .../libnspr4_2%3a4.10.2-1ubuntu1.1_amd64.deb ...
Unpacking libnspr4:amd64 (2:4.10.2-1ubuntu1.1) over (2:4.10.2-1ubuntu1) ...
Selecting previously unselected package libnss3-1d:amd64.
Preparing to unpack .../libnss3-1d_2%3a3.15.4-1ubuntu7_amd64.deb ...
Unpacking libnss3-1d:amd64 (2:3.15.4-1ubuntu7) ...
Selecting previously unselected package libnspr4-0d:amd64.
Preparing to unpack .../libnspr4-0d_2%3a4.10.2-1ubuntu1.1_amd64.deb ...
Unpacking libnspr4-0d:amd64 (2:4.10.2-1ubuntu1.1) ...
Selecting previously unselected package flashplugin-installer.
Preparing to unpack .../flashplugin-installer_11.2.202.400ubuntu0.14.04.1_amd64.deb ...
Unpacking flashplugin-installer (11.2.202.400ubuntu0.14.04.1) ...
Selecting previously unselected package flashplugin-nonfree-extrasound.
Preparing to unpack .../flashplugin-nonfree-extrasound_0.0.svn2431-3ubuntu1_i386.deb ...
Unpacking flashplugin-nonfree-extrasound (0.0.svn2431-3ubuntu1) ...
Processing triggers for update-notifier-common (0.154.1) ...
flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.400.orig.tar.gz
Installing from local file /tmp/tmpROXLsN.gz
Flash Plugin installed.
正在设置 libc-dev-bin (2.19-0ubuntu6.1) ...
正在设置 libc6-dev:amd64 (2.19-0ubuntu6.1) ...
正在设置 libc6-dbg:amd64 (2.19-0ubuntu6.1) ...
正在设置 libnspr4:amd64 (2:4.10.2-1ubuntu1.1) ...
正在设置 libnss3-1d:amd64 (2:3.15.4-1ubuntu7) ...
正在设置 libnspr4-0d:amd64 (2:4.10.2-1ubuntu1.1) ...
正在设置 flashplugin-installer (11.2.202.400ubuntu0.14.04.1) ...
正在设置 flashplugin-nonfree-extrasound (0.0.svn2431-3ubuntu1) ...
Processing triggers for libc-bin (2.19-0ubuntu6) ...


好了,最新版flash安装成功了,重启firefox就Ok了。


不喜欢在命令下,也可以在左边快速启动处,找到ubuntu软件中国,搜索一下flash,就第一个应该是了,叫Mozilla 的 Adobe Flash 插件安装程序。点击安装,完成后一样重启firefox即可。

评论

精彩评论
  • 2015-11-05 00:37:30

    我以前也装逼说用LINUX,用了几天实在受不了,还是回到WIN了